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In this tutorial you will learn the basics of Geographic Imager by working with a series of tutorial exercises. All of the
sub-folders of files, images, data and scripts for the tutorial exercises can be found in the following locations:

Windows XP
C:\Documents and Settings\All Users\Documents\Avenza\Geographic Imager\User Guide, Tutorial & Data

Windows Vista and Windows 7
C:\Users\Public\Public Documents\Avenza\Geographic Imager\User Guide, Tutorial & Data

Mac OS X
/Applications/Avenza/Geographic Imager/User Guide, Tutorial & Data
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Tutorial Exercises

Open Images
Opening a spatial image is similar to opening up any other image.

1. In Adobe Photoshop, choose File > Open. Browse to the folder location of the tutorial images and open
EuropelL.tif and EuropeTR.tif.
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2. Make the EuropeTR:tif file the active document and view the Geographic Imager panel. If the panel is not
visible, choose File > Automate > Geographic Imager: Show Panel.

3. Keep these images open for the next exercise.

Specify a Reference File

A reference file contains coordinates that describe the location, image size, pixel size, and rotation of an image file.
It does not contain actual image data.

1. With the EuropeTRtif file as the active document, click the Reference File Specify... link in the Geographic Imager
panel. This specifies a reference file containing geographic coordinate information for the active document.

2. Select EuropeTRref.tfw and click the Open button. Once opened, the reference file will be listed in the Geographic

Imager panel.
& |E )& |

Ref file: EuropeTRref tfw
Goordinate System: Specify... i
Mode: Standard

¥ Image Mede: RGE Color | 8 Retation: 0.0:000 *

General Corners Misc.
Image Sze: 420 x 453 px
Image Extents:  4.887 x 5.033
Geodetic Extents:  MA
Picel Sze:  0.011 x 0.011

3. Keep these images open for the next exercise.
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Specify a Coordinate System

Some reference files do not store coordinate system information. Using a world file as a reference file requires that
a source coordinate system be specified. For more information on reference files, see Chapter 2 in the Geographic

Imager User Guide.

The EuropeTR.tif was originally made in the WGS 84 coordinate system, however it currently has no coordinate
system assigned. Specify a coordinate system using these steps.

1. With the EuropeTR:tif file still the active document, click the Coordinate System Specify... link in the Geographic

Imager panel. This specifies a coordinate system for the active document.
In the Specify Coordinate System dialog box, click the Specify... button.

In the Select Coordinate System dialog box, expand the Coordinate Systems > Geodetic > World category, select

the WGS 84 coordinate system and click OK.

Datasource:  C:'Program Files\Avenza\Geographic Imager\Data Source Files'geodata. xml

Custom Data:  C:\ProgramData\Avenza\Geographic Imager\pustomsystems. xml m
Folder “|[|@ £ DisplayName* Name Horizontal Datum o
: & NSWC9Z-2 NSWC97-2 NSWC97Z-2
& Parametrop Ze... Parametrop Ze.. Parametrop Zemp 1990 (F Save
& Pz-90 PZ-90 Parametrop Zemp 1990 (F
& Unknown datu.. Unknown datu.. GRS 80
B & Unknown datu... Unknown datu... Naval Weapons Labarator
orth America & Unspecified dat... Unspecified dat.. Not specified (based on G|
ceania & WGS66 WGS 66 World Geodetic System 18
ther = & WGS66 WGS 66 World Geodetic System 1€ =
utdated (Deprec... & Wes72 WGS72 WG51972
outh America & WG572 WGS72 WG51972
! b 3 WG51984
- Projected = e i f

BIE

Search
Folder: World

Find:

(+] (=] [7] [@) @

in |Name E

4. Click OK in the Specify Coordinate System dialog box to finalize the selection. This assigns the WGS 84
coordinate system to the active document.

Specify Coordinate System

Coordinate System:

WGS 84

Same as:

Clele=mlcr™

5. Keep these documents open for the next exercise.
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Transform a Coordinate System

Transforming a coordinate system transforms a georeferenced source image into a destination georeferenced
image with a different coordinate system. In this exercise, the image will be transformed from WGS 84 coordinate
system to British National Grid coordinate system.

With EuropeTRutif still the active document, click the Transform button ] in the Geographic Imager panel.

2. Inthe Transform dialog box, click the Specify... button to select a destination coordinate system. This is different
than specifying a source coordinate system. A destination coordinate system is the coordinate system of the
image after it is transformed.

3. Expand the Coordinate Systems > Projected > Europe > United Kingdom category, select the British National Grid
coordinate system and click OK.

Datasource:  C:\Program Files\Avenza\Geographic Imager\Data Source Files\geodata. xml
: C ata) ray ‘o sl
Custom Data:  C:\ProgramD: graphic Imager [T]
Folder “||® £ Display Name “ Name
- Slovenia '3 British National Grid British National Grid
- Spain &, British Ordinance Survey GRS80 Grid  British Ordinance Surve Save
- Sweden & EDS0/TMON ED50/TMON
- Switzerland ) ETRS89/ Guemsey Grid ETRS89 / Guemnsey Grid
- United Kingd... &) ETRS89 / Jersey Transverse Mercator ETRSS9 / Jersey Transver
 Example Systems...
Morth America ||
Ocesnia E—
1 Otk MIKN [ | C
[ ) [/
Search
Folder: United Kingdom
Find: in [Name [=]

This sets the coordinate system that will be used during the transformation. At this point, Geographic Imager
automatically selects an appropriate datum shift to be performed during the transformation process. If this
datum shift needs to be changed, click the Specify button to open the Specify Datum Shift dialog box and select
the desired datum. See page Geographic Imager user guide for an explanation of datum shift.

4, Change the Pixel Size to 1234.8, leave the other options as the defaults.
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.

Destination Coordinate System

Destination:  British National Grid
[] Same as:  [Select Document [-]

Datum Shift: GB 1936 to WGS 84 (Petroleum) UK - Great Britain and UKCS(reversed)

Pixel Options

Pixel Size: |1934_5 ‘ m

Pixel Dimensions: Keep pixels square

Advanced options.

ling: [Bicubic (best for smooth gradients) [7] tavers:  [leaveintact -
[¥] Trim transparent edges
Performance quality:

Precion:  [Normal [+] stripwidth: [0+ pixels

The pixel size can be changed to any user specified value. This essentially changes the size of the image as each
pixel represents a geographic unit. In this instance, the value was chosen to be near the original value.

5. Click the Transform button in the Transform dialog box. The image is transformed to a British National Grid
projected coordinate system.

[ EuropeTR.tif @ 100% (Layer 0.RGB/®) * — O X

2

6. Make the EuropelL.tif file the active document and click the Transform button. Since this file is in Geotiff format,

it is loaded with a reference file specified as itself, and with the coordinate system with which it was created,
WGS84.

Geographic Imager 3.2 Tutorial Guide 7



7. Click the Same As option and select EuropeTR.tif (British National Grid) from the Same As drop-down list.

Transform

Destination Coordinate System

Destination:  British National Grid Specify... | | FromFie...
Same as:

EuropeTR. tif (Eritish National Grid) [=]

Datum Shift: GB 1935 to WGS 84 (Petroleum) UK - Great Sritain and UKCS(reversed)

Pixel Options
Pixel Size: 1228.60306467

Pixel Dimensions: Keep pixels square

Advanced options

Resampling: |Bicubic (best for smooth gradients) [=] tayers:  [Leave intact
Tiim transparent edges

Performance fquality:

Precision:  Normal [=] strip width: 50 pixels

8. Click Yes when prompted to update the pixel dimensions to match the selected document (e.g. for the purpose
of mosaicking). Do not check the Always use the current selection check box.

Geographic Imager

Do you want to update the pixel dimensions to match these of the selected
document (mosaicking into a non north-up aligned document s not currently

supported)?

[T] Always use the current selection

Click the Transform button in the Transform dialog box to confirm these settings.

Both images are now in the same projected coordinate system (British National Grid) and have the same
pixel size.
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10. Close all documents without saving before proceeding to the next exercise.
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Mosaic Images

In the next set of exercises, several image documents will be mosaicked together, transformed as one image, and

exported as multiple image tiles.

In Adobe Photoshop, choose File > Open. Open the EuropeTL.tif, EuropelLL.tif, EuropelLR.tif and EuropeTR.tif files.
Make the EuropeTR.tif file the active document, click the Reference File Specify... link in the Geographic Imager
panel, and choose EuropeTRref.tfw as the reference file.

Click the Coordinate System Specify... link in the Geographic Imager panel, select one of the other images in the
Same As drop-down list to specify the coordinate system as WGS 84 and click OK.

Specify Coordinate System

Coordinate System
|was 84

) Select

) Unknown

@ Same As: |EurepelR. tf (WGS 84)

Browse...

Cancel

4. Make the EuropeTL.tif the active document and click the Mosaic button

Notice that it is in the British National Grid coordinate system. This will be the destination document, other
images will be mosaicked and transformed into this document. Images can have different coordinate systems,
different pixel sizes or contain rotation and still be mosaicked. The images will inherit the coordinate system and

pixel size of the destination document.

Note: Transformations during mosaic are not supported when the destination document contains rotation. To

mosaic into a destination document containing rotation the images to be mosaicked must have the same
coordinate system, pixel size and rotation angle.

5. Alist of available documents for mosaicking are displayed in the Available Documents list of the Mosaic dialog
box. Click the Select All button to select all available images and click the double right arrow button to move

them into the Selected Documents list.

[
Dastrution Dacmant
BurnpetL, oF [lieteh havtons ]
Sourre Documents
Aadaie Documents

Docuimest Mem *  Incompathiy

Erew ks rvet Lo
Sdboaried % gt it s

Resamping: e fbest for smoofh gradents)
Brrlrmance fouslty:

Precson:  Homal

10 | Geographic Imager 3.2 Tutorial Guide

Docurment Mame
Eusnpel tf
Curnpeih.tf

=] twven:  Merge raster lvers ]

o] oo maen: 5 soveis




The Advanced Transformation Options in the Mosaic dialog box are the same as the Transform dialog box. These
options are used to resample the layers, set strip size and leave the layers intact or merge them. In this tutorial, leave
them at their default settings. Read more about these options in Chapter 4 of the Geographic Imager User Guide.

6. Click OK to complete the mosaic.

The image is mosaicked in the EuropeTL.tif document window with a coordinate system of British National Grid.
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Inspect the Adobe Photoshop Layers panel. Notice that the other documents are now mosaicked in the
EuropeTL.tif document. The layers are kept intact, however, since there is no need to retain the layer structure
for the next exercise, the image will be flattened.

7. Click Layer > Flatten Image.
8. Keep the EuropeTL.tif document open for the next exercise and close the other open documents.
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Tile Images

1.
2.

8.

12

=]
With the mosaicked image the active document, click the Tile button in the Geographic Imager panel.
In the Tile dialog box, select the By Number of Tiles option, and type 3 into both the Horizontal and Vertical text
boxes. This will result in the creation of nine new images.

In the Overlap frame, type 100 into both Horizontal and Vertical text boxes. Ensure Pixels is chosen in the Units
drop-down list. This creates a 100 pixel overlap with each of its adjacent images.

In the Naming drop-down list, select Separate Row/Column Numbers. Each image will contain the name of the
original image plus a reference to the row and column to which it represents.

Select GeoTIFF Files from the Reference File Format drop-down list and click OK.

Tiing Schema §
@ ByMNumber of Ties () By Size of Tiles
Horizontal: |3 Horizontal: | 182 Units: |Pixels
Vertical: 3 Vertical: 307
Overlap
Horizontal: | 100 Vertical: | 100 Units: [Pixels [+]
Destination
Total Files: [ [7] Keep images open
Naming: Separate Row/Column Numbers [=]
Reference File Format: GeoTIFF Files |z|

Click OK and specify a location (directory) to save the tile images. In this case, use the default file name and click
Save. If a TIFF Options dialog box appears, click OK to accept the default settings.

When the tile process is completed, navigate to the destination directory and view the tile images. The naming
separate row/column numbers format is appended to the file name: the tile EuropeTL_1_1.tif belongs in the
first row and first column; EuropeTL_1_2.tif in the first row and second column; and EuropeTL_1_3.tif in the first
row and third column, and so on.

EuropeTL 1 1.4if  EuropeTL 1 2tif  EuropeTL 1_3.4if

Close all open documents without saving.
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Georeference an Image

The image for this exercise is a satellite image of central Rio de Janeiro, Brazil, taken from Google® Earth. The image
has no reference file, however it has four red pushpins indicating the position of the image control points. Using the
Georeference function, assign a real world position to each control point.

1. In Adobe Photoshop, choose File > Open. Browse to the tutorial folder and open the file Rio de Janeiro.jpg. Note
that in the Geographic Imager panel, the Reference File field is not specified because no corresponding reference
file is present in the image folder.

2. Inthe Geographic Imager panel, click the Georeference button .

The image is in a Pseudo-Mercator projection (as used in Google Earth and Google Map) but the position of the
control points are provided in latitude and longitude format in the WGS84 geodetic system.

3. Inthe Format frame, click the Specify... link to set the Image Coordinate System.
4. Inthe Input Format dialog box, click the Specify button to specify the image’s coordinate system.
5. Expand the Coordinate Systems > Projected > World category, select WGS84 / Pseudo-Mercator and click OK.

6. Backin the Input Format dialog box, click the Use alternate input coordinate system check box to enable this option
and click the corresponding Specify button. This ensures that the world values being entered are those of the
coordinate system chosen in the next step.

7. Expand the Coordinate Systems > Geodetic > World category, select WGS84 and click OK.

8. Backin the Input Format dialog box, choose Decimal Degrees (D+[.d*]) from the Geodetic Coordinates Format
drop-down list, change the Geodetic Precision to 6 and click OK.

Image Coordinate System:
WGS 84 [ Pseudo-Mercator Spedify... Clear
Use alternate input coordinate system:
Destination: WGS 84
Same as:
Datum Shift: [No Datum Shift Required] Spedfy...
Geodetic Coordinates Format:
Decmal Degrees (D+[.d*]) E

Coordinate Format Example

Decimal Degrees, with optional direction indicator.
Examples:
754440, 54.9777N | 79,44

Display Decimal Precision:

Geodetic Precision: |6 = Projected Predision: |3 |

Geographic Imager 3.2 Tutorial Guide | 13



9. Atthe top of the Georeference dialog box, click the Zoom In button and zoom to the first control point
located at the upper-left corner of the image.

Note: If the overview window is in the way, close it by clicking the Show/Hide Overview button or move it—
right-click (or hold Ctrl or Cmd and click) the overview window and drag to a new position.

10. Click the Add Point button and click precisely at the tip of the red pushpin number 1 on the image preview
(zoom-in more if necessary). This adds a first control point named Point 1, a new row is added in the control
point table.

E] @ @ Image Size: 2198 x 2036 px | Zoom: |81%
= 3 > » r -

11. In the control point table, enter the world coordinate (WX longitude and WY latitude) for Point 1 (top-left):
. WX= -43.256355
.« Wy= -22.872398

| =) E Method: | Affine E'
Use MName PX PY WK Wy PXY Error
1 Point 1 11z 155 -43.256355 -22.872398

tll n +

1/1 points in use | Georeference is invalid
At least 3 points are required

12. Using the Zoom In , Zoom Out , Zoom to Extent @ and Pan buttons or the overview window (click
and drag to draw new extents), magnify the location of the red pushpin number two on the upper right corner
of the image.

13. Click the Add Point button and click precisely at the tip of second pushpin.

14. In the control point table, enter the world coordinate for Point 2 (top-right) as follow:
- WX= -43.243635
.« Wy= -22.872597

14 | Geographic Imager 3.2 Tutorial Guide



15. Repeat the same procedure for red pushpin number 3 in the lower right corner of the image. The world
coordinate for Point 3 (lower right) are:
. WX= -43.242564
- Wy= -22.884070

16. Repeat the same procedure for the fourth red pushpin in the lower left corner of the image. Notice that the world
coordinates of the fourth point are populated with an estimation based on the position of the other control
points.

Note: The registration Method is set by default to Affine—this method requires a method of three points (usually
four for control). When using a higher polynomial degree method (e.g. Cubic Polynomial) more control points
are required to determine the image registration. Higher polynomial degree methods can be necessary for
distorted images (skewed through scanning process for example), or if the chosen image coordinate system
is approximative.

17. Instead of keeping the estimated world coordinates of Point 4 (lower left), change them as follow:
. WX= -43.255150
. WY= -22.883450

The control point table contains several columns on the positioning error of each control point (in pixel or world
unit). The world coordinate values entered are considered accurate for this exercise, so any error should be due
to the position of the control point on the image preview.

18. To reduce the error values, center and magnify the image preview to a control point to be moved, then click the
Select Points button @ and click and drag the desired location to a more precise pixel position. Look at the

error columns in the control point table to see if this improves the positioning accuracy. AWX and WY error of
0.5 meters is very acceptable for this image.

Method: |Affine [=]

Name PX PY WX WY PXY Error PX Error  PY Error WXY Error WX Error WY Error

=
#

»-
=]

Point1 113 155 -43.256355 -22.872398

~
=

Point 2 1918 186 -43.243635 -22.872597

w
=

Point 3 2071 1953 -43.242564 -22.834070

=
=

Point 4 284 1858 -43.255150 -22.883450 0338965 -0.257043|0.220966 0.265732 0.201519 0173215

4/4 paints in use | Georeference is valid

Forward Residual: 0.330459 (x: 0.250581, y: 0.215435) | Inverse Residual: 0. 255204 {X: 0196568, Y: 0. 168560}

19. Leave the Mode option as GCP mode and click OK. Click No to the warning message regarding the mode.
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The image is now georeferenced. The Geographic Imager indicates a reference named Rio de Janeiro.tfw file and
the selected image coordinate system (WGS84 / Pseudo-Mercator).

) 88 |5 |F) &) ()

hd

Referanca file:
Coordinate System:
Mede:

Image Mode: RGB Color | 8 Rotation: 0.0000 *

Rig de Janetio. tiw
WGS 84 / Pseudo-Mearcator
GCP

(]

General

Imags Size:
Image Extents:
Geodetic Extents:
Pizeal Size:

Corners Misc.

2158 x 2036 px

1722516 x 1597 809 m
0.01547362 x 0.01322425 deg
0.784 x 0.785 m

20. To save the reference file and image file (although the image has not been modified as such), choose File > Save
in the Adobe Photoshop main menu. The reference file, Rio de Janeiro.tfw, is saved in the same folder as the image
file. Click Yesin the warning message regarding the storage of point data

21. Close all documents and continue with the next exercise.

16
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Quick Georeference

Quick Georeference is a fast method to georeference an image. This method requires two conditions:

The image is not rotated (image aligned to True North).

Only two points are needed to georeference, however these points must not contain the same coordinate
in either the X or Y pixel or world unit (i.e. two points cannot be aligned on the same X or Y axis on either the
image or world system).

In Adobe Photoshop, open EuropeTR.tif. The image is not rotated and is aligned to True North.

In the Geographic Imager panel options menu, choose Preferences. The panel options menu button is located at
the top-right corner of the panel. **

Uncheck the Use internal referencing format if available check box and click OK.

Brmtarmricms
Dt Reberercs Format: | Workd s =
Une nterral refermncrng format [
wemlable (GesTIFF, ECW etz =
SerpangiArtions Support: U]}

Save a copry of pecvedererce as an REF
e oo Bopart -5 Pah e Mainr L

[eset ol arrees nsion

In the Geographic Imager panel, click the Georeference button.
In the Georeferencing dialog box, click the Add Control Point button ™ twice. In the table below, type the pixel
coordinates (PX and PY) and world coordinates (WX and WY in decimal degrees) of two points located at the

Northeast and Southwest corners of the image:

Northeast point (Point 1)
PX =419, PY pixel =0
WX =1.76, WY = 60.00

Image Saes 420 x 4535w | Zoom: 5%

Southwest point (Point 2)
PX=0,PY =452
WX =-2.89 WY =54.98
EE He @@ st e =

1 =1} Poim 1 49 o 1m0 0000

J
22 pants i usse | Georeference ek
At lmant 1 puars s eecarmd

Hode Format

Ltaretad eartard afns Hacdfrmabon! Imige Dosedrale Srtem: Tomaile,,
Irgut Coordeate System; Nk
B GO lrvprtas bt of o] i

Notice that the world coordinates expand to three decimal places. This happens because the Projected Precision
is set to three decimal places.
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6. Click the Quick Georeference button and select the option By Two Reference Points (North/South aligned).

The image is now georeferenced and two additional reference points are added. If necessary, click and drag
the horizontal line below the image view to adjust the size of the table. Notice that there are no pixel or world

e GEB

@@

By Tie Point (North/South aligned)...

ference Poin

aligned)

Copy From Document (same size/reference)...

Copy From File (same size/reference)...

—

60.000

wy PXY Error

54980

2/2 points in use | Georeference is invalid

At least 3 points are required

coordinate errors.

v
LS

Image Size: 420 x 453 px | Zoom

s ]

e i N—
Use Mame PX PY WX WY PXY Error
1 il 0 [t} -2.890 60.000 0.000 -0.00f
2 NE 419 0 1.760 60.000 0.000 -0.00f
3 S 0 452 -2.890 54.880 -0.00)
4 SE 419 452 1.760 54.980 0.000 -0.00|
4 [ T ] »
4/4 points in use | Georeference is vaid
Forward Residual: 0.000 {x: 0.000, y: 0.000) | Inverse Residual: 0.000 (X: 0.000, Y: 0.000)
Mode Format
@) Standard (maintains affine transformation) Image Coordinate System: Specify...
Input Coordinate System: N/A
(©) GCP (maintains list of points) Input Format: Ground Units.

e |

FEAA EE

7. Inthe Format frame, click the Image Coordinate System Spe«ify... link.
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8. Inthe Input Format dialog box, click the Specify button. In the Specify Source Coordinate System dialog box,
expand the Coordinate Systems > Geodetic > World category, select the WGS 84 coordinate system and click OK.

Input Format

Image Coordinate System:

WGS 84

Destination:
Same as:

Datum Shift:
Geodetic Coordinates Format:
Decimal Degrees (D+[.d*])

Coordinate Format Example

Examples:
754440, 54.9777N | 79,44

Display Decimal Precision:

Geodetic Precision: |6 &

[] use alternate input coordinate system:

[No Coordinate System Specified]

Dedimal Degrees, with optional direction indicator.

Projected Precision: (3 |5

OK

Spedify...

Spedify...

B

9. Click OK to close the Input Format dialog box.

The Format frame coordinate information is updated.

Mode

@ Standard {maintains affine transformation)

(©) GCP (maintains list of points)

Format
Image Coordinate System: WGS 84
Input Coordinate System: WGS 84
Input Format:

Dedmal Dearees (D+.d

10. In the Georeferencing dialog box, click OK to save the settings.

The document was successfully georeferenced.

11. Keep this image open for the next exercise.

GEQOGRAFHIC IMAGER
j=]-]
() &) & 2] & &) @)
Reference file: EuropeTR.tfw
Coordinate System: WGES 24 (H]
Mode:  Standard
- Image Mode: RGEB Color | 8 Rotation: 0.0000 °
General Corners Misc.
Image Size: 420 x 453 px
Image Extents: 4.66105785 x 5.03110613 deg
Geodetic Extents:  4.86109785 x 5.03110819 deg
Pixel Se:  0.01108785 x 0.01110813 deg
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Convert to GeoTIFF
1. With EuropeTR.tif as the active document, open the Geographic Imager panel options menu and choose Convert
to GeoTIFF.

2. Inthe Save dialog box, specify a name and location to save the GeoTIFF. Specify the name of the image as
EuropeTRCrop.tif and click Save.

=

2l

[B8l Geographic Imager

—,
OU = |_,_ « Tutorial DaEa 3

Folders v | Name - Date taken Tag
|4h Public Dacuments « | | Lendsat 7 Multispectral
| Avenza 1 Rocky Mountain 3D La...

. Geographic Imager 1 Sample Scripts
| Legal Info . Europel Ltif
|| User Guide, Tutorial &D: | o Europel Rtif

| Tutorial Data . EuropeTL tif
| Landsat7 Multispect: 7. EuropeTR.tif
| Rocky Mountain 30 L
I/ Sample Scripts

mn

|\ MAPublisher 8 A -
IR ET CMlF uropeTRCrop tif| -
Save as type: [GeoTlFF files(™.tif ".tiff) s I

The reference information is saved in the new GeoTIFF file and is displayed in the Geographic Imager panel.

(%) (&) |86 |22 |¥) | &) | &)

Reference file: TRCrop.fif

Coordinate System: WGS 84 ([}
Mode:  Standard

v Image Mode: RGB Color | Rotation: 0.0000 *

General Comers Mis.

Image Sze: 420 x 453 px

Image Extents: 4 88888847 x 5.03333322 deg

‘Geodetic Extents: 4.88686687 x 5.03333333 deg.
Pixel Sze:  0.01111111 x 0.01111111 deg

3. Keep this document open for the next exercise.
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GeoCrop

The GeoCrop function crops georeferenced images based on defined crop areas.

1. With EuropeTRCrop.tif as the active document, click the GeoCrop button in the Geographic Imager panel.

2. Inthe GeoCrop dialog box, choose Geodetic from the Unit Type drop-down list. Leave the Coordinate Format as
Decimal Degrees and type in the following values:

Top-left corner Bottom-right corner

Long:-2.766 deg Long:-1.655 deg

Lat: 56.094 deg Lat: 55.229 deg
. N

GeoCrop

Dimensions: 1.111000 x 0.865000 deq ( 100 x 78 px, Raw Size: 7.62KB )

Unit Type: ‘Geadaﬁc

Coordinate Format: Decimal Degrees (D+[.d*])
Top-eft Corner

]

Bottom-right Corner

deg Long: |-1.655 deg
[-2.89000000 -> 1.77105785]
lat:  |56.094 deg lat: |55.229 deg

[60.00000000 -> 54.96889381]

Long: |-2.765

[-2.89000000 -> 1.77109785]

[60.00000000 ->» 54.96889381]
Pixel Round Options

Partial Pixels: @ Round to Closest () Always Use &) Discard

The crop area marquee (dashed red border shown in the image preview) is drawn to the coordinates specified
above. This functions similarly to the Adobe Photoshop crop tool. Resize it to change the crop area.
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3. Click and drag a corner of the crop area marquee to resize it.

GeoCrop
Image: (267, 174) | World: (0.07312648, 58.06752212) deg
Dimensions: 2.829952 x 2.809867 deg ( 255 x 253 px, Raw Size: 63KB )
Unit Type: ‘Geodeﬁc
Coordinate Format: Decmal Degrees (D+[.d"]) [=]
Topeft Corner Bottom-right Corner
[-2.89000000 -> 1.77109785] [-2.89000000 -> 1.77109785]
lat:  |58.03420354 deg lat  |55.22433623| deg
[60.00000000 -= 54.96889381] [60.00000000 -> 54.96889381]
Pixel Round Options
Partial Pixels: @ Round to Closest () Always Use @) Discard

As the marquee is resized, the corner coordinate values are updated.

4. Click OK to complete the GeoCrop.

B europeTRCrop.tif @ 100% RGE/B*  — O X

5. Close all open documents without saving.
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Advanced Import

The Advanced Import function is similar to the GeoCrop function in the previous exercise. The difference is that an
image does not have to be opened before cropping. Instead, Advanced Import opens the GeoCrop dialog box first,
then crops the image during an Adobe Photoshop import. It may be useful for images that would require a long

load time.

1. In the Geographic Imager panel, click the Advanced Import button. This tool can also be accessed in the File
menu, choose Import > Geographic Imager: Advanced Import.

2.

Reyert

Fi2

Place..

Export

Automate
Scripts

FileInfo..

L
AltsShifter Ctrls]

Print..
Print One Copy

Ctil+P

Alt+Shift-Ctrl+ P

Exit

CirleQ

data folder and click Open.

Variable Data Sets...
Video Frames to Layers..

» s fmimgr. ]
Notes...

WIA Support...

In the Advanced Import - Select a file dialog box, select the EuropelL.tif file from the Geographic Imager tutorial

Bl Advanced Import - Select a file

[

vorite Links

Documents
Dropbox
Recent Places

More »

Folders

|.1b Public Documents
L Avenza
. Geographic Imager

1| LegalInfo
|\ User Guide, Tutorial & Data
|\ Tutorial Data
Landsat 7 Multispectral
. Rocky Mountain 3D Lar
. Sample Scripts

File name: Europel L i

m|

o
@U'l || <« User Guide, Tutorial & Data » Tutorial Data »

G
Mame

I

m ==

Date modified

Landsat 7 Multispectral FL{:::‘:(:“ D:Stail: 2
File Folder i
File Folder
Sample Scripts :.h Eg::?:ir‘_Ramp Examplésrd
File Folder mﬂ 8 7 KEC
Europel Ltif ["T9 Europelrtif
TIF File TIF File
609 KB !d 608 KB
EuropeTL.tif Il EuropeTR.tif
TIF File TIF File
729 KB | 579 KB
Yukon Water.dem
DEM File
938 MB

Type Size

- Fmmontan ]
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The Advanced Import dialog opens a dialog window, exactly the same as the GeoCrop dialog, with a preview of
the EuropelLL.tif image.

& @ = 2oom 570 [
Dimensions: 470 ¥ 453 i {Raw Sre: 185,808 )
o = )
Topdeft Comer Battom-right Cormer
= o - | Lo
fo-> 4] [o-> 4]
v £ v |4 I
B>459 [-»453
Dot
PartalPurk: G RoundimCosest () Mwayslse ) Discaed

3. Intheimage preview, click and drag the mouse to draw a crop marquee. Change the Unit Type to Geodetic.

Ee BE BEE Zoom s [ K]

Demersioras: 2.677778  3.522222 deg [ 368 x 347 p, Rarw Size: 82,0668 |
Uit Type: (Geodens )

EE

Coordrute Format: | Decemsl Degrees L8711
Tog-seft Comer

Long: | 4.8333333 deg
L2544 > 287777

The Top-left and Bottom-right Corner boxes are populated with the coordinates from the crop marquee.
4. Click OK to complete the crop.
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The image is imported and cropped.

L

5. Close all open documents without saving.
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Export to Geospatial PDF

1. With EuropelLL.tif as the active document, open the Geographic Imager panel options menu and choose Export

to Geospatial PDF.

In the Save dialog box, specify a name and location to save the Geospatial PDF. Specify the name of the image
as EuropelL.pdf and click Save.

s
n Geographic Imager ﬂ
S~
i) ‘ < User Guide, Tutorial & Data » Tutorial Data » - | ‘,| | Search Tuto pel |
Organize = MNew folder = - l@l
=
Adobe PDF *  Name Date Type
Avenza 5 S =
Landsat 7 Multispec... 7/8/2010 12:45 PM File folder
Geographic Imager . -
Rocky Mountain 3D..  7/8/2010 12:45 PM File folder
Legal Info AT )
Sample Scripts 7/8/201012:45 PM File folder
User Guide, Tutorial & Data
. Tutorial Data |
Landsat 7 Multispectral
. Rocky Mountain 3D Landscape Da
Sample Scripts
MAPublisher &
i - W ] 3
SNV ¥ A
File name: Europel L.pdf 2
Save as type: | Geospatial PDF files(*.pdf) 'I
= Hide Folders [ swe | [ conca |
L

The file's reference information is saved in the new Geosaptial PDF file. The image is now accessible in any

softwawre with PDF support, and the image’s georeferencing is accessible in software supporting the Adobe
Geospatial PDF standard.
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Import DEM File

Import DEM files easily using Geographic Imager. Some DEM files contain background or water areas (usually at
a zero height) and need to be isolated before it can be styled. To achieve this, background pixels areas have to be

defined in the Import DEM file dialog box advanced settings.

1.
2.

In Adobe Photoshop, browse to the Tutorial data folder and open Yukon Water.dem.

In the Import DEM file dialog box, click the Create New Schema button (@],

Import DEM file

‘Open as elevation data
Select Schema: |Auto-stretched

Maps file-specific range of elevation data to Adobe Photoshop grayscale t
colorspace.

This method allows for the best predision preservation and automatically generates
high-contrast maps, however the results may not be easily mosaickable or
compatible with other DEM files.

[T] Don't show again Remember schema changes

i

This opens the Edit DEM Schema dialog box. The Schema Name is already populated with the name of the file. It
also populates the Lowest and Highest Elevation values according to the DEM’s data range.

Edit DEM Schema

Schema Name: Yukon Water
Lowest Elevation: |0
Highest Elevation: | 1058

File DataRange: [0 ->1058] | ||

Meter

Vertical Unit:

3. Since these values do not need to be modified click OK to close the Edit DEM Schema dialog box.

Import DEM file

‘Open as elevation data
Select Schema: | Yukon Water: 0 -> 1058 m

Maps spedified range of elevations to Adobe Photoshop grayscale colorspace.
Using common data ranges allows for importing multiple files using equal schema
and therefore compatible and mosaickable. Mote that elevation values outside of
the spedified data range will be mapped to the min / max color values.

[T] Don't show again Remember schema changes

e

The Select Schema now reflects the data range of the DEM.
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4. Inthe Import DEM file dialog box, click the Advanced button.

Advanced DEM Schema Seftings [
Unigue values list
|Display as transparent pixels E
=== = Cancel
-32767.00

The Unique values list is currently set to Display as transparent pixels. The value -32767.00 is a predefined value
that represents no data. This value can not be deleted and is common to all DEM files. To display elevations as
transparent pixels populate this list with elevation values. This is not required for this exercise.

5. Choose Display as background pixels from the Unique values drop-down list and click the Add new value
button [@], A new value is created. Double-click <new value> and type in a value of 0.

~

s
Advanced DEM Schema Settings.

Unigue values list
Display as background pixels [=]
Cancel

£0.00

L J

6. Click OKto close the Advanced DEM Schema Settings and Click OK to accept the settings of the Import DEM file
dialog box to finish the import.
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joen © 117% (Rakgioend, Gray 18] * =

P TOTTP  TOPTT I P T "'];s":_":

BT ] ey 1,758 414 G

BT ] e 37041 »

The chosen custom DEM schema maps the range of elevation to the Adobe Photoshop grayscale colour-space,
displaying the highest contrast possible. The Advanced DEM Schema Settings created a layer titled Background
where all elevations with a value of 0 are displayed as black. If multiple values are used to display background
pixels, each value will be a different shade of black.

Since the water layer is now isolated, use Adobe Photoshop tools to assign it a different colour. Similarly, a
gradient map can be applied to the elevation data layer.

7. Keep this document open for the next exercise.
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Terrain Shader

Terrain Shader can be used for stylizing an open DEM file or other image with z-values, or to quickly create a Gradi-
ent Map adjustment layer using predefined or user loaded color maps .

1. Continue working with Yukon Water.dem from the previous exercise or refer to the “Import from DEM” tutorial on
page 26 for instructions on opening and configuring a DEM file. for use.

2. Onthe Geographic Imager panel select the Terrain Shader tool ® . This opens the Terrain Shader dialog.

Terrain Shader

-

1058 m

846 m

834m

423m

211lm

om

[¥] Apply Color Map

[] Apply Shaded Relief

angle: [45

Apply only to selection

Method:  |Stretch gradient along image's DEM schema ( 0 -> 1058 )

[ — T

¢
e

[] 7] Use Continuous color

B0 E

Intensity: (2

3. By default the World Gradient Map, or the last used colour ramp, is applied to the DEM. Note that 0 elevation
values are displayed as background as specified by the DEM import settings from the previous exercise.

4.  Click the Import Color Map From File 2J icon in the Terrain Shader dialog. Select the file Colour Ramp Examples.grd

from the Tutorial Data folder.

Impart Gradient
e —
oetnis bt |
ol |

lm

Position: 79%, Rek 91, Green: 57, bloe: 28
Crndentbowme: | Bevaton 3

Color Space;  AGD

Low Bevation: 0

| Use Contrushus Color
tigh Bevaton: | 1058

5. Choose Elevation3 from the Color Map pull down menu and Click Import.
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6. Click the Edit Selected Color Map Icon * to launch the Edit Color Map dialog.

Edit Color Map

Color Map Name: |Custom: Yukon Water.dem | Use Continuous Color

LowElevation: @ |m  High Elevation: m
Elevation (m)  Position (%)  Color Detail

1 529517 5.00488 - Red: 167, Green: 174, Blue: 204

2 370403 35.0008 - Red: 193, Green: 163, Blue: 147

3 687597 64.9902 - Red: 107, Green: 75, Blue: 28

4 1005.05 94.9951 - Red: 73, Green: 38, Blue: 28

[ Addcolorstep | | Deletecolorstop | [

Clear Color Stops | | ResetColorStops |
Update preview image in the Terrain Shader dialog

Right click the color swatch of the table entry for Color Stop 1. Choose Edit Color Stop. This opens the Select Color
for Color Stop dialog. Enter new color values of Red: 204, Green: 198, Blue; 181.

r
5] Select Color for Color Stop.

Basic colors

Custom colors

|
| o o

[ Add to Custom Colors ]

Click OK to close the dialog.
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7. Backin the Terrain Shader dialog check the Apply Shaded Relief checkbox. Leave the angle at the default value of
45 degrees. Adjust the intensity to 5 and click OK.

i ! pi:
!’;f‘ 7
2t

Reset Import DEM File Schema and Advanced Settings

Custom DEM schema settings and Advanced DEM Schema Settings are saved even after an Adobe Photoshop
session is closed. Both settings will be applied to each DEM image opened if values are not deleted.

Reopen the Yukon Water.dem file (or any DEM file).

In the Import DEM file dialog box, choose Auto-stretched from the Select Schema drop-down list.

Click the Advanced button to open the Advanced DEM Schema Settings dialog box.

Choose Display as background pixels from the Unique values drop-down list and select the 0.00 entry (or any
other entries). Click the Remove selected value(s) button [2/ and click OK to close the Advanced DEM Schema
Settings dialog box.

Click OK to close the Import DEM file dialog box to finish the import.

Close the document without saving.

HwnN =

o »

Custom DEM schema settings and Advanced DEM Schema Settings are now reset.
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Using Actions with Geographic Imager
This exercise demonstrates how to automate Geographic Imager by recording an action that opens an image and
transforms the coordinate system to WGS 84. See Chapter 10 - Automating Geographic Imager for more details.

Note: Actions should only be used on the computer it was created on. Actions are not cross platform and use

absolute paths.

1. Inthe Adobe Photoshop menu, choose Window > Actions to open the Actions panel.
In the Action panel option menu (top right corner), choose New Set. Rename it Open - Transform WGS 84 and click OK.

This creates an action set folder to store the action.
Select the new action set folder and choose New Action from the Action panel option menu. Rename the action

to EuropeTL to WGS 84.

2.

Name: EuropeTL to WGS 84
Set: Open - Transform WGS 84~ Cancel

Function Key: None - Shift Control

Color: [] None -

A function key and colour for the action can be set, however, it is not needed for this exercise.

4. Click Record to create the action.

Notice that the red Begin recording button in the Actions panel is enabled. From this point on, all operations will
be recorded to the action until it is stopped.

[ (] Default Actions B
= [ Testing
= Transform - BNG
P Transform
= 1] Open - Transform WGS 84

b d EuropeTi to Was 84

ma P+ O G F

15}
i
&

EREEER
[ [FE[a

In the Adobe Photoshop menu, choose File > Open. Browse to the folder location of the tutorial images and

5.
open EuropeTL.tif.

6. Choose File > Automate Menu > Geographic Imager: Transform. In the Transform dialog box, perform a coordinate
system transformation to WGS 84.

7. Inthe Action panel, click the Stop Playing/Recording button. Notice the action steps are recorded beneath the
action name.

8. To play back the action, close the image without saving, select the EuropeTL to WGS 84 action and click the Play

button in the action panel.

Congratulations, you have completed the Geographic Imager Tutorial Guide. Move onto the Adobe Photoshop
exercises in the next section. Also see the Geographic Imager User Guide for more detailed information.
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Adobe Photoshop Tutorial Exercises

The following tutorial exercises use existing Adobe Photoshop functions to manipulate spatial imagery to create
affects such as shaded relief, colour ramps, 3D elevation models, false-colour composite and pan sharpened
images. In addition, learn how to record measurements with the Ruler Tool and resample and sharpen images.

These tutorial exercises differ from the previous set of exercises because they mainly involve the use of Adobe
Photoshop tools, functions and filters. Geographic Imager allows non-native formats such as DEM files, MrSID, ECW
and JPEG 2000 to be imported and used with a Photoshop environment while streamlining the cartographic work
flow.

These exercises are only examples of what Geographic Imager for Adobe Photoshop is able to do. Combined with
creative uses of both sets of tools, a wide range of image manipulation techniques are achievable.

Content

Create a 3D Representation with an Orthographic TEXTUIe .. .......iuii it e nenns 35
L0 T 201 =T oo 38
Create a False-ColoUr COmMPOSITE. . ...ttt ettt ettt ettt et ettt e et e e et e e e e nenns 40
Lo T 0 T 11 o1 o T 42

Resample and Sharpen
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Create a 3D Representation with an Orthographic Texture

Note:  This tutorial can only be run on Adobe Photoshop CS4 or CS5 on a computer with a video card that supports OpenGL
to make use of the 3D functionality. In Windows, choose Edit > Preferences > Performance to see if your video card sup-
ports it. In Mac OS X, choose Photoshop > Preferences > Performance. GPU settings are enabled if supported.

How to run the script using the sample data:

1. In Adobe Photoshop, choose File > Scripts > Browse and navigate to the following locations:
.\User Guide, Tutorial & Data\Tutorial Data\Sample Scripts

2. Select the Rocky Mountains.jsx script and click Load.

The script will run and perform the following tasks automatically:

+  OpenaDEM

«  Create a 3D plane from the data

«  Modify the vertical exaggeration of the 3D scale

+  Position the 3D model

+ Load and drape a texture image (ortho image) on the 3D model
«  Set the final 3D model position

«  Modify Canvas size for final output

« Add anew layer and draw a gradient to represent the sky

Note: When creating a 3D representation, georeferencing is not maintained.

The 3D elevation model is now ready for the final output.
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For an additional effect, the 3D elevation model can be viewed in stereoscopic 3D.

1. In the Adobe Photoshop menu, choose 3D > Render Settings.

2. Inthe 3D Render Settings dialog box, check the option for Stereo type.

3. If viewing the image using classic red-blue glasses, specify the Stereo type to Red/Blue. If using a lenticular lens
select Vertical Interlaced.

4. Set the Parallax to 80. Parallax adjusts the distance between the two stereo cameras. A higher value increases
the three-dimensional depth but reduces the depth of field, making items ahead or behind the focal plane
appear out of focus.

5. The Focal Plane determines the position of the focal plane relative to the center of the image bounding box.

Negative values move the plane forward and positive values move it backward. Leave the Focal Plane at its

default of 0.

3D Render Settings ﬁ
| Preset: Custom Render Settings N
Cancel
Face Style: oo
Texture: | Difuse Set Defaults
Upan Exparting Video: | Shodo Preview
["|Render for Final Output [TRemove Backfaces

Edge Styler

wertex Stylet | constant

Radjus:

JBitme Stler
Wolume Styler [ yorms

-

Sterso Type! Red/Blue
Paralizx: 80

@

Lenficular Spacing:

=

1% ipi

Focal Piane: g

6. Click OK to complete the 3D render settings.

The image is now ready for stereoscopic 3D display.
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Modify the Rocky Mountains.jsx elevation model script to accommodate user data. This script is only compatible with
Adobe Photoshop CS4 or CS5. To perform this tutorial with data other than the sample data, the following param-
eters need to be satisfied:

A DEM and texture image are needed of the same area to create one 3D model

One of the images should be transformed to match the other images size, pixel size, and coordinate system

The script needs to be modified to reflect the location of the images.

In the operating system file browser, go to the following location:
.\User Guide, Tutorial & Data\Tutorial Data\Sample Scripts

Open the Rocky Mountains.jsx script in a text editor.

At the beginning of the script, there are two paths that need to be modified to enable this script to be used with

custom data. Modify the appropriate paths depending on the operating system (Windows or Mac).
«  Modify the first path (yourPath) to specify the location of the elevation model (DEM, DTED)

+  Modify the second path (yourPath2) to specify the location of the texture or image to be draped over the

elevation model

17 // include required Geographic Imager subroutines
#include "GeographicImagex.jsxinc”

nis script is incompatible with earli

return;

var yourPath;
if( Folder.fs == "Windows" ) //Windows Vista or Windows 7
i

ial & Data\\Tutorial Data\\Rocky Mountain 3D Landscape Data\\Rocky Mo

e Data\\Rocky M:

and Settings\\ALl Users\\Doc:

er Guide, Tutorial & Data/Tutorial Data/Rocky Mo
ser Guide, Tutorial & Data/Tutorial Data/Rocky Mountai:

nts\\Avenza\\Geographic Imager\\User Guide, Tutorial & Data\\Tutorial Data\\Rocky Mountain 3D Landscape Data\\Rocky Mountains|
s and Settings\\All Users\\Documents\\Avenza\\Geographic Imager\\User Guide, Tutorial & Data\\Tutorial Data\\Rocky Mountain 3D Landscape Data\\Rocky Mountair

7" Opens the DEM file
OpenDEM (yourPath, "Auto-stretched")

Once the correct paths are modified, save the script using a different file name. Run the saved script by

choosing File > Scripts > Browse. Find the location of the saved scripts and click Load.
Review your image and make adjustments to the script as necessary.
Close all open documents before continuing with the next exercise.
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The Ruler Tool

Analysis tools can be used to record and export measurements with georeferenced images. These tools were
originally introduced in Adobe Photoshop CS3 and were designed for the medical community. They also serve as
valuable tools for cartographers.

1. In Adobe Photoshop, choose File > Open and browse to the Landsat 7 Multispectral folder and open Band 8
(Panchromatic), 15 meters.tif.

This is an image of downtown Toronto circa 2004. The projected coordinate system is NAD 83 UTM Zone 17N in
meters. The Geographic Imager panel displays the pixel size. A precise measurement is dependent on the pixel
size. For this example, 1 pixel is equal to 15 x 15 meters and provides a moderately accurate measurement.

B ) & |32 F | @) @)

Reference file: Band & {Panchrom.. }, 15 metres tif

Coordinate System: NADS3 [ UTM zone 17N (H]
Mods:  Standard
= Image Mode: Gray Scake | & Rotation: 0.0000°
General Corners Misc.

Image Size: 1022 x 384 px
Image Extents:  15330.000 x 14760.000 m
Geodetic Extents:  0.18855896 x 0.13551283 deg

Foeel Sga: 15000 x 15.000 m

Note: Non-square pixels prevent the recording of correct measurements when using measurement tools. This can
be rectified by using the Geographic Imager Transform function and changing the Pixel Options to keep
pixels square.

2. From the Analysis menu, choose Set Measurement Scale > Custom.
3. Inthe Measurement Scale dialog box. Set the Logical Length to 15.
Note: Up to four decimal places can be entered in the custom field to provide enough accuracy for all images.

4. Type the Logical Units as meters.

The Logical Units box stores what unit the pixel size is in. A custom preset measurement scale is useful when
using images with the same pixel size.

Measurement Scale &J

Presets: Custom -

Pixel Length: 1
Logical Length: 15 Save Preset...
Logical Units: meters Dele set.
1 pixels = 15.0000 meters

i The Ruler tool has been activated while this dialog is open.

You may use it to measure the pixel length for use in your scale.

5. Click OK to close the dialog box.
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6. Before measuring, choose Window > Measurement Log to open the Measurement Log panel. The panel appears
either as floating or docked at the bottom of the screen.

7. Inthe Adobe Photoshop Tools panel, select the Ruler Tool .If not visible, click and hold the button to display
the flyout menu). It is also accessible by choosing Analysis > Ruler Tool.

8. Take a measurement of a section of Toronto. As shown below, click anywhere on the map and drag the Ruler
Tool. Click again to complete the measurement. A measurement line is drawn on the image.

9. Inthe Measurement Log panel, click Record Measurements.

For the above example, the distance recorded is approximately 2720 meters (Length column). Your results may
vary depending on how long of a ruler line you drew.

MEASUREMENT LOG

Record Measurements

Label |Date and Time

[0 Rulers  03/07/2009 .. Band 8 (Panchromati... Ruler Tool Custom (1 pocels = 15.0000 meters) meters

The Ruler Tool is not the only tool used to record measurement. Use the Lasso, Magic Wand and Quick Select tools
to select an area and click the Record Measurement button to record it to the Measurement Log. All measurements
can be exported to a tab delimited Unicode text file (select the desired rows and click the export button in the up-
per right corner of the Measurement Log panel.

10. Close the document without saving.

Note: Remember the resolution of the image will reflect how accurate the measurements will be. Analysis tools can
not be used with non-square pixels because each side has a different length.
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Create a False-Colour Composite

Another powerful remote sensing tool in Adobe Photoshop is the ability to create a false-colour composite image.
Multispectral images contain information inside and outside the visible electromagnetic spectrum. To use this
information, the wavelengths outside the visible spectrum need to be reassigned to the visible spectrum so that it
is visible to the human eye. This tutorial will create a false-colour composite of downtown Toronto and surrounding
suburban areas.

Often multispectral satellite images will consist of several greyscale images, with each image containing one of the
wavelengths or bands of the electromagnetic spectrum. These images need to be combined into one image. The
Adobe Photoshop function called Merge Channels merges images to create false-colour or true-colour composites.
You may easily identify distinct features by their unique spectral signature.

1. In Adobe Photoshop, browse to the Landsat 7 Multispectral folder and open the following images:

+  Band 2 (Green), 30 meters.tif
+  Band 3 (Red), 30 meters.tif
+  Band 4 (Near Infrared), 30 meters.tif
Note: When creating false-colour composites, images must be of the same image resolution and have the same
spatial extents. If the images need to be cropped, it is recommended to use the Geographic Imager GeoCrop
function to assure that the extents of the images remain consistent.

2. From the Windows menu, choose Channels to open the Channels panel.
3. Inany active document window, click Merge Channels from the Channels panel options menu.

CHANNELS
ﬂ New Channel...

& Gray 0N Y Duplicate Channel...
Delete Channel

New Spot Channel...
Merge Spot Channel

Channel Options...

Split Channels
Merge Channels...

Panel Options...

TR

Close
Close Tab Group

4. Inthe Merge Channels dialog box, select RGB Color in the Mode drop-down list and click OK.

Merge Channels Lg
Mode: RGB Color R
Channels: 3
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5. Inthe Merge RGB Channels dialog box specify the following channels:
« Red: Band 4 (Near Infrared), 30 meters.tif
«  Green: Band 3 (Red), 30 meters.tif
«  Blue: Band 2 (Green), 30 meters.tif

M

erge RGB Channels.

Specify Channels:
Red: Band 4 (Near Infrared),...
Green: Band 3 (Red), 30 metr...

Blue: Band 2 (Green), 30 me...

Cancel

Liky

6. Click OK to complete the merge.

Note:

Imager Preferences dialog box.

SERBEEE

Reference file:

Untitied 1.tfw

o]

Goordinate System: NADS3/ UTM zone 17N
Mode:  Standard
= Image Mode: RGE Color | 8 Rotation: 0.0000°
General Corners Misc.
Image Sze: 511 x 452 px
Image Extents: 1£330.000 x 14760.000 m.
Geodefic Extents:  0.18855056 x 0.13551283 deg
Pixel Sza: 30,000 30.000 m

A reference file called Untitled-1.tfw is created in the default reference format specified in the Geographic

A false-colour composite image with georeferencing is created. The band combination chosen makes vegetation
appear in shades of red because vegetation reflects a lot of near infrared light. The brighter the red, the healthier
the vegetation. Urban areas appear blue-grey. The bright red areas at the top of the image belong to the prestigious

Rosedale Golf Club.

7. Close any open documents without saving.
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More about Landsat 7 band combinations

R,G,B | Description
3,2,1 | The“nature colour” combination. It provides the most water penetration.
4,3,2 | Standard “false-colour” combination. Vegetation shows in red.

74,2 | The“nature-like” combination. Sand, soil and minerals show in multitude of colour. Fires would appear in
red. It provides clear imagery in desert region.

7,53 | The“nature-like” combination. Sand, soil and minerals appear in variety of colour.
54,1 | Good for agricultural studies. Healthy vegetation shows in bright green colour.

7,54 | Provides best atmospheric penetration. Vegetation shows in blue. Useful for geological study.

73,1 Rocks may appear in variety of colour. Good for the geological study.

Note: Some multispectral images may be provided as a single image that stores extra channels (called alpha chan-
nels in Adobe Photoshop). To create false-colour composites from these images in Adobe Photoshop, the
channels must first be split into single gray scale images (Channels panel option menu > Split Channels). Then
channels can be merged and reordered as described above.

Pan Sharpen

Another useful tool Adobe Photoshop provides is the ability to intelligently resample images. Pan sharpening (short
for panchromatic sharpening) the use of a single band to increase the spatial resolution of a multispectral image. A
multispectral image contains a higher spectral resolution of a panchromatic image, while often a panchromatic im-
age will have a higher spatial resolution than of a multispectral image. A pan sharpened image represents the best
of both worlds which is essentially a sensor fusion that gives a multispectral image higher spatial resolution.

1. In Adobe Photoshop, browse to the Landsat 7 Multispectral folder and open the following images:

- Band 8 (Panchromatic), 15 meters.tif
- Band 1(Blue-green), 30 meters.tif

«  Band 2 (Green), 30 meters.tif

«  Band 3 (Red), 30 meters.tif

In this exercise, the panchromatic image will be combined with a multispectral image in true colour, however, any
false-colour composite combination can be used.

2. From the Windows menu, choose Channels to open the Channels panel.

3. Inany 30 meter resolution active document window (Band 1, 2 or 3), click Merge Channels from the Channels
panel options menu.

Note: If Band 8 is chosen, Merge Channels will be disabled.
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4. Inthe Merge Channels dialog box, select RGB Color in the Mode drop-down list and click OK.
5. In the Merge RGB Channels dialog box specify the following channels:

+  Red: Band 3 (Red), 30 meters.tif
«  Green: Band 2 (Green), 30 meters.tif
+  Blue: Band 1 (Blue-green), 30 meters.tif

Merge RGE Channels L&J

Specify Channels:

Red: Band 3 (Red), 30 metr... - Cancel
Green: Band 2 (Green), 30 me... -

Blue: Band 1 (Blue-green), 3... =

6. Click OK to complete the merge.

Since the merged image is at 30 meter resolution, it is necessary to resample it to match the resolution of the
panchromatic image (15 meter resolution).

7. With the merged document window active, choose Image > Image Size.

8. Ensure Constrain Proportions and Resample Image check boxes are checked. Choose Bicubic (best for smooth
gradients) as the resampling method.

9. In the Pixel Dimensions frame, select percent from the units drop-down list.

Geographic Imager 3.2 Tutorial Guide
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10. Enter 200 in the width dimension (height automatically changes to 200 due to constrain proportions) and click
OK to complete image scaling.

Image Size [
— Pixel Dimensions: 2.88M (was 736.6K)
Width: 200 percent ¥ :l -
]
Height: 200 percent b
— Document Size:
Width: 14.194 inches i :|
8
Height: 13.667 inches -
Resolution: FE pialsfinch =
[¥] Scale Styles
Constrain Proportions
[¥] Resample Image:
Bicubic (best for smooth gradients) b4

11. From the Image menu, choose Mode > Lab Color.
12. In the Channels panel options menu, click Split Channels.

The merged image is split into three images: Lightness, a and b.

Untitled-1 b @ 66.7% (Gray/8#) * X i

&l T T Tz =
P i T e BT i T

The splitimages have an”_L,”_a" or,’_b"appended to the end of the document name. The a and b channels
carry green-red and blue-yellow information respectively. Our process is to substitute the panchromatic image
for the Lightness channel. Adobe Photoshop CS3 users will not see docked windows, only floating ones.

The following step involves some trial and error. The intent is to make the image brightness and contrast match the
Lightness channel as much as possible. Ignore areas of water or vegetation and concentrate on roads and build-
ings. Often panchromatic images contain data that extend into the infrared, therefore vegetation and areas of water
appear differently. The higher resolution of the panchromatic image, the more contrast it will appear to have.

Note: Ignore vegetation and areas of water because panchromatic images often contain near infrared data.

13. Make Band 8 (panchromatic), 15 meters.tif active and create a Brightness/Contrast adjustment layer. Choose Layers >
New Adjustments Layer > Brightness/Contrast.

14. In the Brightness/Contrast settings (Adjustment panel for CS4 and CS5), adjust Brightness to +100 and Contrast

to +35 and click OK.
ADJUSTMENTS =
Brightness/ Contrast

Brightness: 100

Contrast: E
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15. Create a second adjustment layer. Choose Layers > New Adjustments Layer > Levels.
16. In the Levels settings (Adjustment panel for CS4 and CS5), adjust the midtone input level to 0.90 and the
highlight input level to 230 and click OK.

ADJUSTMENTS

Levels  cysom -

E

ray -
L..I'HH || [P
5.00

230

4
rd
rd
il

0

YR @8 <0 3F

17. To properly merge channels, the layers need to be flattened first. Choose Layer > Flatten Image.
18. In the Channels panel options menu, click Merge Channels. In the Merge Channels dialog box, select Lab Color in the
Mode drop-down list and click OK.

Merge Channels g
Mode: Lab Color -
Channels: 3

19. In the Merge Lab Channels dialog box specify the following channels:
« Lightness: Band 8 (Panchromatic), 15 meters.tif
« a:Untitled-1_a
«  b: Untitled-1_b

Merge Lab Channels. @

Specify Channels:

Lightness: Band 8 (Panchromatic),... i
a: Untitled-1_a -

b: Untitled-1_b -

Note: The Untitled documents were created from splitting the channels in step 14. Untitled documents may not be
appended with the number 1, however, be sure that the final character corresponds to the channel e.g.a=

“Untitled-4_a".

20. Click OK to complete the merge.
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21. Choose Mode > RGB to convert the image back to RGB mode.
22. Leave the document open for the next exercise.

CHANNELS

Note: This exercise is a guide to enhance images for display or printing purposes, this method involves subjec-
tive judgment to pixel colour adjustments and should not be used for scientific purposes. The colours of
the pan-sharpened image will look different from the original RGB image because panchromatic data (from
Landsat 7) extend into the infrared, most notably vegetation and areas of water.
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Resample and Sharpen

Adobe Photoshop sharpen filters can increase the detail of the image. The Sharpen filter menu has a variety of
sharpening tools. These tools also involve some trial and error to achieve enough sharpening without overdoing it.
Two sharpening filters are explained below.

The Unsharp Mask

This filter sharpens an image by increasing contrast along the edges of an image. It locates pixels that differ in value
from the surrounding pixels, this option can be modified by changing the threshold. The radius of the region to
which each pixel is compared is also an option that can be modified.

Smart Sharpen

This filter has more advanced controls not available in the Unsharp Mask filter. This filter will allow control over the
amount of sharpening that occurs in shadow and highlight areas. The document should be viewed at 100% to get
an accurate view of the sharpening.

- Amount: Sets the amount of sharpening. A higher value increases the contrast between edge pixels, giving the
appearance of greater sharpness.

+  Radius: Determines the number of pixels surrounding the edge pixels affected by the sharpening. The greater
the radius value, the wider the edge effects and the more obvious the sharpening.

» Remove: Sets the sharpening algorithm used to sharpen the image. Gaussian Blur is the method used by the
Unsharp Mask filter. Lens Blur detects the edges and detail in an image, and provides finer sharpening of detail
and reduced sharpening halos. Motion Blur attempts to reduce the effects of blur due to camera or subject
movement. Set the Angle control if you choose Motion Blur.

+  Angle: Sets the direction of motion for the Motion Blur option of the Remove control.

« More Accurate: Processes the file more slowly for a more accurate removal of blurring.

In the Smart Sharpen dialog box, click the Advanced option to display the Shadow and Highlight tabs. Adjust sharp-
ening of dark and light areas using these tabs. If the dark or light sharpening halos appear too strong, reduce them
with these controls, which are only available for 8-bits and 16-bits-per-channel images:

- Fade Amount: Adjusts the amount of sharpening in the highlights or shadows.

- Tonal Width: Controls the range of tones in the shadows or highlights that are modified. Move the slider to the
left or right to decrease or increase the Tonal Width value. Smaller values restrict the adjustments to only the
darker regions for shadow correction and only the lighter regions for highlight correction.

+  Radius: Controls the size of the area around each pixel that is used to determine whether a pixel is in the
shadows or highlights. Moving the slider to the left specifies a smaller area, and moving it to the right specifies
a larger area.
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1. With the image still open from the previous exercise, choose Filter > Sharpen > Smart Sharpen.

2. Set the following parameters in the Smart Sharpen dialog box:
+  Set the Amount to 15%
+  Set the Radius to 2.0 pixels

«  Set Remove to Lens Blur
«  Check the More Accurate checkbox

Smart Sharpen =)
[ preview
@ Basic ) Advanced
[~ Settings: Default - — B i -
Amount: 15 % l

10
Radius: 2.0 pixels
105

Remove: Lens Blur -

angle: [0 o

More Accurate

3. Click OK.

Features appear to have more detail when compared to the image prior to sharpening. Again, this will involve some
trial and error if the results are not satisfactory, experiment with settings if more sharpening is needed.

Congratulations, you have completed the Adobe Photoshop Tutorial Exercises. For more in-depth information on
Geographic Imager tools and features, see the Geographic Imager User Guide.
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